CVE-2020-13948: Apache Superset远程代码执行漏洞

360CERT [三六零CERT](javascript:void(0)😉 昨天

img

报告编号:B6-2020-091901

报告来源:360CERT

报告作者:360CERT

更新日期:2020-09-19

0x01 漏洞简述

2020年09月19日,360CERT监测发现 Apache 邮件组 发布了 superset 代码执行漏洞 的风险通告,该漏洞编号为 CVE-2020-13948 ,漏洞等级:高危,漏洞评分:7.2

经过身份验证的远程攻击者通过发送特制的请求包,可以造成 远程代码执行 影响。

对此,360CERT建议广大用户及时将 superset 升级到最新版本。与此同时,请做好资产自查以及预防工作,以免遭受黑客攻击。

0x02 风险等级

360CERT对该漏洞的评定结果如下

评定方式等级
威胁等级高危
影响面有限
360CERT评分7.2

0x03 漏洞详情

CVE-2020-13948: 代码执行漏洞

Apache Superset是由Airbnb开发用于数据探索和数据可视化的开源软件,能够处理大量数据。能够通过点击操作快速创建数据报表/数据大屏。

Apache Superset 中存在一处逻辑漏洞,在其模板引擎处理特殊的内容时,允许访问 python os 软件包,进而导致任意代码执行。

经过身份验证的远程攻击者通过发送特制的请求包,可以造成 远程代码执行 影响。

0x04 影响版本

- apache:superset: <0.37.0

0x05 修复建议

通用修补建议

升级至 Apache Superset 0.37.1

0x06 相关空间测绘数据

360安全大脑-Quake网络空间测绘系统通过对全网资产测绘,发现Apache Superset具体分布如下图所示。

搜索语法: service.response:"/superset/welcome"

img

0x07 产品侧解决方案

360城市级网络安全监测服务

360安全大脑的QUAKE资产测绘平台通过资产测绘技术手段,对该类漏洞进行监测,请用户联系相关产品区域负责人或(quake#360.cn)获取对应产品。

img

0x08 时间线

2020-09-15  @Will Barrett在Apache邮件组发布通告2020-09-19  360CERT发布通告

转载自https://mp.weixin.qq.com/s/SJPSKmKANsxfjNodFEWViQ

©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页